Skocz do zawartości

  •         

Zdjęcie

CS:GO i Linux Mint

CS:GO Linux Mint problem

6 odpowiedzi w tym temacie

#1 kapi00z

kapi00z

    Advanced Member

  • Użytkownik
  • 75 postów

Napisano 20 marzec 2014 - 11:17

Witam!

Otóż napotkałem problem z odpaleniem CS:GO w linuxie (Linux Mint 16 Petra 64bit). Problem objawia się tak:
Ve3wyoi.png
Próbowałem na wine, potem playonlinux, na obu ten sam błąd.
Mój komputer to: E8400@3.9GHz, 2x2GB 1066MHz, ATI Radeon HD4830, MSI neo2-fr, Zasilacz 400W (Delta Electronics)
apt-get update było chyba z 4 razy, 3 restarty, powoli kończą mi się pomysły, ktoś miał coś podobnego albo wie jak zaradzić?


Intel i7-6700K + Noctua NH-D15, ASRock Z170 Extreme4, Kingston HyperX 4x4GB 2133MHz DDR4, Gigabyte HD7770 1GB, Crucial bx100 250GB, EVGA Supernova 550 G2, SiletniumPC Gladius x60 Pure Black.
Kacper  xD


#2 PiotrQ

PiotrQ

    AS Monaco FC

  • Użytkownik
  • 2129 postów

Napisano 21 marzec 2014 - 05:39

Na twojej karcie gra powinna chodzić.

Myślę że może to być wina wersji wine lub braku bibliotek czy złe ustawienia. Zainstaluj też najnowsze stery dla tej karty. Poza tym mógłbyś też poszukać rozwiązania na necie.
http://askubuntu.com...ux-steam-client
http://appdb.winehq....rsion&iId=26545
http://forum.linuxmi...p?f=47&t=120342

Na jakiej wersji wine grasz? Widziałem jak jeden gra na v1.5

ps.
Playonlinux to jest wine z rozszerzoną konfiguracją
Teoria jest wtedy gdy wszystko wiemy, a nic nie działa.
Praktyka jest wtedy gdy nic nie wiemy, a wszystko działa.
A tera połączmy teorie z praktyką. Nic nie wiemy i nic nie działa.

#3 kapi00z

kapi00z

    Advanced Member

  • Autor tematu
  • Użytkownik
  • 75 postów

Napisano 22 marzec 2014 - 12:57

Wine 1.6.1, playonlinux też świeżutki, co do sterowników to jest taki problem, że oficjalne sterowniki ati beczą mi, że muszę mieć maksymalnie kernel 3.4, gdzie mój jest 3.11, próbowałem masy ustawień, ogólnie nie miałem problemu ze starszymi grami w wine (tzar, diablo), ale nowszych zasadniczo nie próbowałem, sterowniki muszą być dobre, bo Left 4 Dead 2 na OpenGL chodziło normalnie, bez żadnych błędów ani problemów, musiałem tylko używać komendy "force_s3tc_enable=true steam" w konsoli żeby odpalić go w wersji linuxowej i móc grać w lefta (cs 1.6 chodził ładnie). Właśnie pobieram inną grę, żeby sprawdzić, czy będę miał podobne błędy (CoD: MW3).
Jest jakiś sposób żeby wymusić instalację tych sterowników do karty, bez Catalist Center i innych gówien, sam sterownik? Zdaje mi się, że po prostu wyrzuca błędy z GUI (jestem zasadniczo świeżak w linuxie, ale cośtam próbuję się uczyć).


Intel i7-6700K + Noctua NH-D15, ASRock Z170 Extreme4, Kingston HyperX 4x4GB 2133MHz DDR4, Gigabyte HD7770 1GB, Crucial bx100 250GB, EVGA Supernova 550 G2, SiletniumPC Gladius x60 Pure Black.
Kacper  xD


#4 PiotrQ

PiotrQ

    AS Monaco FC

  • Użytkownik
  • 2129 postów

Napisano 22 marzec 2014 - 04:29

Zobacz czy ze strony ati można pobrać stery pod linuxa i sobie pobierzesz te które wspierają tą karte. Słyszałem że z winem jest tak że czasem gra działa lepiej na starszej wersji i o ile się nie mylę to playonlinux pozwala przypisać wersję wine do danej gry.

Poza tym to problem może być w brakujących bibliotekach lub wpisach do rejestru.
Teoria jest wtedy gdy wszystko wiemy, a nic nie działa.
Praktyka jest wtedy gdy nic nie wiemy, a wszystko działa.
A tera połączmy teorie z praktyką. Nic nie wiemy i nic nie działa.

#5 kapi00z

kapi00z

    Advanced Member

  • Autor tematu
  • Użytkownik
  • 75 postów

Napisano 23 marzec 2014 - 10:35

Wine miało starszą wersję (jakieś około 1.5), ale jak na niej nie szło, to zrobiłem update i ciągle nic. Jak mówiłem, sterowniki na stronie ati są, ale muszę mieć kernel < 3.4
Próba odpalenia CoD: MW3 też się nie powiodła


Intel i7-6700K + Noctua NH-D15, ASRock Z170 Extreme4, Kingston HyperX 4x4GB 2133MHz DDR4, Gigabyte HD7770 1GB, Crucial bx100 250GB, EVGA Supernova 550 G2, SiletniumPC Gladius x60 Pure Black.
Kacper  xD


#6 PiotrQ

PiotrQ

    AS Monaco FC

  • Użytkownik
  • 2129 postów

Napisano 23 marzec 2014 - 12:29

To wgraj odpowiedni kernel i stery. Jak te stery z ati nie pomogą to możesz wrócić na swój aktualny (można mieć duzo kerneli na linuxie).

 

ps

Teraz mnie tak oświeciło :) Czy ty wogóle wgrywałeś jakiś stery do grafiki na mincie swoim? Jak nie to zapewne korzysta z domyślnych które prawdopodobnie nie obsługuja grafiki dedykowanej do końca (albo wcale) i podejrzewam że tu może być problem.


Użytkownik PiotrQ edytował ten post 23 marzec 2014 - 12:33

Teoria jest wtedy gdy wszystko wiemy, a nic nie działa.
Praktyka jest wtedy gdy nic nie wiemy, a wszystko działa.
A tera połączmy teorie z praktyką. Nic nie wiemy i nic nie działa.

#7 kapi00z

kapi00z

    Advanced Member

  • Autor tematu
  • Użytkownik
  • 75 postów

Napisano 23 marzec 2014 - 09:42

Jutro spróbuję wgrać ten kernel, dam znać jak poszło.


Intel i7-6700K + Noctua NH-D15, ASRock Z170 Extreme4, Kingston HyperX 4x4GB 2133MHz DDR4, Gigabyte HD7770 1GB, Crucial bx100 250GB, EVGA Supernova 550 G2, SiletniumPC Gladius x60 Pure Black.
Kacper  xD




Dodaj odpowiedź



  



Również z jednym lub większą ilością słów kluczowych: CS:GO, Linux Mint, problem

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych

  Copyright power by: ITPC.NET.PL